?

Log in

No account? Create an account
LiveJournal Client Discussions [entries|archive|friends|userinfo]
LiveJournal Client Discussions

[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

ljArchive 0.9.3 [Jul. 20th, 2004|02:28 am]
LiveJournal Client Discussions

lj_clients

[fg]
This is a pretty big update, although most of the changes are under the hood.

For those of you who emailed me with errors you encountered in the previous version, they should be resolved in this version.  The main issue was with clone servers and free accounts, and ljArchive now supports both properly.

The main interface has been completely redone.  Here are some screens:ljArchive is now ready to be ported to linux - implemented in mono.  I've looked over the mono BCL and ljArchive's core library is completely compatible.  I'm looking for a mono developer familiar with gtk# (or wt# or whatever else) to work with me.  The ljArchive core library is VERY easy to work with and fully (sorta) documented.  Here's an example of the code you'd write to interact with it.  So if you're interested, please email me or leave a comment.

I'm also looking for speakers of other languages willing to help me translate some bits of very mundane text such as "ljArchive encountered an error" because ljArchive now supports localization.

Unfortunately for upgrading users, this version breaks compatibility with the old file format, so you'll have to create a new archive and resync.  I won't be making a habit of breaking compatibility.

There are lots of new features.  For a more thorough listing of them, check out the revision history.

You can download the new client here.
linkReply

Comments:
[User Picture]From: pookfreak
2004-07-20 04:38 pm (UTC)
Ok I'm getting an error - I had 0.9.2 installed and then installed 0.9.3 on top of it and then ran it and got

ljArchive Error: ljArchive encountered the following fatal error: One or more of the types in the assembly unable to load.

Then I uninstalled completely (using XP uninstall) and reinstalled 0.9.3 and tried it again and got the same error.

Any ideas?
(Reply) (Thread)
[User Picture]From: fg
2004-07-20 04:55 pm (UTC)
hi pookfreak,

the installer for ljArchive doesn't do a very good job of updating yet, without completely uninstalling the previous version.

to fix your problem, uninstall ljArchive,

then find the directory for it in your program files (it will still be there even though you uninstalled it), and delete the whole directory.

then reinstall.

then let me know if it worked     :)
(Reply) (Parent) (Thread)