?

Log in

No account? Create an account
UTF 8 text sent using atom - LiveJournal Client Discussions [entries|archive|friends|userinfo]
LiveJournal Client Discussions

[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

UTF 8 text sent using atom [Dec. 5th, 2005|11:16 am]
LiveJournal Client Discussions

lj_clients

[verevkin]
I'm sending the UTF8 (russian) text to the http://www.livejournal.com/interface/atomapi/verevkin/post
The text is "Тест UTF8", what means "Test UTF8".
The HTTP reply I receive is:

Status Code: 201
Response Body:


Тест в UTF8




At the post I see the text, but when I try to edit it, I see the next contain: "Тест в UTF8".

Is it a bug? Any ideas, please.
linkReply

Comments:
(Deleted comment)
(Deleted comment)
[User Picture]From: verevkin
2005-12-08 09:04 am (UTC)

Re: Works for me ...

I don't want to have unicodes in my post body, I need UTF-8 symbols. I don't see from your example that it's what you have.
Thank you.
(Reply) (Parent) (Thread)
(Deleted comment)
[User Picture]From: verevkin
2005-12-09 09:39 am (UTC)

Re: Works for me ...

When I post this text from the browser I see UTF-8 (not unicodes). I expect to see the same using the atom interface. The charset converting will crash the friendlents of my friends. The posting using atom API worked fine for me with the previous atom implementation (untill Apr 2005).
(Reply) (Parent) (Thread)
(Deleted comment)
(Deleted comment)
(Deleted comment)
[User Picture]From: verevkin
2005-12-10 09:31 am (UTC)
I don't use PERL client, I use Java. So unfortunately I can't check your scripts.
I still don't understand if you have an example of the XML entity to send and LJ won't change the charset to unicodes? Otherwise I see it as the bug that should be fixed on the LJ atom implementation. When the LJ receives the UTF8 string it should not convert anything to unicodes (escapes) as well as it does from the browser.
(Reply) (Parent) (Thread)