Log in

No account? Create an account
LiveJournal Client Discussions [entries|archive|friends|userinfo]
LiveJournal Client Discussions

[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

Crosspost Updated [Nov. 29th, 2005|08:55 pm]
LiveJournal Client Discussions


I should really mention that I upated Crosspost recently... 0.2.1 Alpha!


Changes in this version include complete MySpace blog support as well as a completed update to the Blogger API.

Currently supported blog services are:
  • Livejoural
  • Blogger
  • Myspace
  • Xanga

Give it a whirl. If you have ideas for added features, go here.

Posted by Crosspost! software.

[User Picture]From: trippingbilly
2006-01-11 10:17 pm (UTC)
Did you see the comment listing out the way I ran it on Linux?

Please don't use "-jar crosspost-jar-0.2.2-alpha.jar" for now... at least until I can bundle all the linux-specific libraries into a linux-specific jar. Try to run it by specifying the classpath and the java.library.path and giving it the fully qualified class name.

I pasted in the exact procedure (that worked for me, by the way) into a previous comment.
(Reply) (Parent) (Thread)
From: davidcougle
2006-01-11 10:25 pm (UTC)
ok, i see it.

extracted swt files to swt/

you broke a line in your post which makes things confusing, so I tried this

java -cp swt:crosspost-jar-0.2.2-alpha.jar -Djava.library.path=swt com.abditory.crosspost.CrosspostMain
Exception in thread "main" java.lang.UnsatisfiedLinkError: no swt-win32-3138 in java.library.path
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1682)
at java.lang.Runtime.loadLibrary0(Runtime.java:822)
at java.lang.System.loadLibrary(System.java:992)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
at org.eclipse.swt.internal.win32.OS.(OS.java:18)
at org.eclipse.swt.widgets.Display.(Display.java:125)
at com.abditory.crosspost.CrosspostMain.main(Unknown Source)
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-12 03:11 pm (UTC)
In your classpath parameter, you're including the swt folder, not the jar. The -cp parameter should read:

"-cp swt.jar:crosspost-jar-0.2.2-alpha.jar"
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-12 03:12 pm (UTC)
I just realized that *I* entered that incorrectly in my previous post. Sorry! =)
(Reply) (Parent) (Thread)