Log in

No account? Create an account
LiveJournal Client Discussions [entries|archive|friends|userinfo]
LiveJournal Client Discussions

[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

Crosspost Updated [Nov. 29th, 2005|08:55 pm]
LiveJournal Client Discussions


I should really mention that I upated Crosspost recently... 0.2.1 Alpha!


Changes in this version include complete MySpace blog support as well as a completed update to the Blogger API.

Currently supported blog services are:
  • Livejoural
  • Blogger
  • Myspace
  • Xanga

Give it a whirl. If you have ideas for added features, go here.

Posted by Crosspost! software.

[User Picture]From: ompimec
2006-01-16 02:25 am (UTC)
I downloaded CrossPost, but when I try to launch it, I receive the following error:

Could not find the main class. Program will exit.

If it matters, I have Windows ME.
(Reply) (Thread)
[User Picture]From: trippingbilly
2006-01-16 02:30 am (UTC)
The OS shouldn't matter, but do you know what version of Java you have running on your system?
(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-16 04:32 am (UTC)
No, I don't. I really don't know much about java, so would you mind telling me how to find out what I have (and how to update it if it's an old version)? I'd really appreciate it!
(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-16 11:32 pm (UTC)
Nevermind, I found that I have Java 1.4.2.
(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-16 11:43 pm (UTC)
Rather than trying to executre the program normally, I tried to actually open it with Java itself. I received the following error:

An error occurred while launching/running the application.

Category: Invalid Argument error

Could not load file/URL specified: C:\WINDOWS\TEMP\javaws2

So is my problem simply that I lack that file/folder?
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-16 11:47 pm (UTC)
It sounds like you don't have a fully functioning Java Runtime Environment. "javaws2" is Java Web Start, and your system should not be trying to run that for an application like this.

Try going over here:


Download "JRE 5.0 Update 6". Once it's installed (installation instructions can be found at http://java.sun.com/j2se/1.5.0/jre/install-windows.html), try to run Crosspost again. You shouldn't have to re-install Crosspost for it to work.
(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-17 09:47 pm (UTC)
Well, I installed the new Java, and the program no longer displays the error message. The problem now is that when I try to execute the program, nothing happens at all. I double-click the desktop icon, my mouse cursor turns into the arrow+hourglass, then after a few seconds, it simply stops and my cursor returns to normal.

I'm sorry for being such a pain, but do you have any clue what may be causing this?
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-17 09:56 pm (UTC)
You're not being a pain. =)

I know I said that you shouldn't have to re-install Crosspost for it to work, but on a whim, can you try that for me? Just uninstall it from "Add/Remove Programs" and install it using the executable available on http://crosspost.sourceforge.net.

Also, can you pull up a command prompt and run "java -version" and paste the output of that here?
(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-18 01:33 am (UTC)
Well, I'm still in the process of downloading it again (slow dial-up connection), but I got the output:

java version "1.5.0_06"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode)

It's all Greek to me, of course ^_^;

Also, is there any real difference between the .exe and .jar download files? I tried both before, but I only tried the .exe since updating my Java. I'm trying the .jar again now.
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-18 01:37 am (UTC)
Stick with the .exe. The .jar is purely cross-platform and would require additional libraries for you to run it successfully.

The output looks good. I need to look at the launch script to figure out where the problem might lie. I'll have to do that tomorrow though.
(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-18 02:17 am (UTC)
Thanks for working so hard to help me, I really appreciate it!

After redownloading the .exe file and installing it, I'm still getting the "nothing happens" effect.
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-18 02:28 pm (UTC)
I built a new launcher that should give us some output and let us see what's happening a little better. Please download this file and copy it to wherever you installed Crosspost. By default it's in "C:\Program Files\Crosspost". Once you copy it there, just run it from that directory and let me know what output you get from it.

(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-18 07:03 pm (UTC)
Just so you know...

When you run the new launcher I posted above, you can right click on the black screen with all the green text and you'll get an option to copy the contents to the clipboard, which you can then paste here.

(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-18 09:55 pm (UTC)
Execute: "C:\Program Files\Java\jre1.5.0_06\bin\javaw.exe" -Djava.library.path="lib\swt-libs" -jar "dist\crosspost.jar"

Might this shed some light on my pesky little issue ^_^?
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-19 06:50 pm (UTC)
Not yet. =/

I just uploaded another version of CrosspostVerbose.exe. Please download using the above link and test again. This *should* provide even more output. It should actually bring up a console window when it tries to run...
(Reply) (Parent) (Thread) (Expand)