?

Log in

No account? Create an account
Crosspost Updated - LiveJournal Client Discussions — LiveJournal [entries|archive|friends|userinfo]
LiveJournal Client Discussions

[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

Crosspost Updated [Nov. 29th, 2005|08:55 pm]
LiveJournal Client Discussions

lj_clients

[trippingbilly]
I should really mention that I upated Crosspost recently... 0.2.1 Alpha!

http://sourceforge.net/projects/crosspost

Changes in this version include complete MySpace blog support as well as a completed update to the Blogger API.

Currently supported blog services are:
  • Livejoural
  • Blogger
  • Myspace
  • Xanga


Give it a whirl. If you have ideas for added features, go here.

Posted by Crosspost! software.
linkReply

Comments:
[User Picture]From: ompimec
2006-01-17 09:47 pm (UTC)
Well, I installed the new Java, and the program no longer displays the error message. The problem now is that when I try to execute the program, nothing happens at all. I double-click the desktop icon, my mouse cursor turns into the arrow+hourglass, then after a few seconds, it simply stops and my cursor returns to normal.

I'm sorry for being such a pain, but do you have any clue what may be causing this?
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-17 09:56 pm (UTC)
You're not being a pain. =)

I know I said that you shouldn't have to re-install Crosspost for it to work, but on a whim, can you try that for me? Just uninstall it from "Add/Remove Programs" and install it using the executable available on http://crosspost.sourceforge.net.

Also, can you pull up a command prompt and run "java -version" and paste the output of that here?
(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-18 01:33 am (UTC)
Well, I'm still in the process of downloading it again (slow dial-up connection), but I got the output:

java version "1.5.0_06"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode)

It's all Greek to me, of course ^_^;

Also, is there any real difference between the .exe and .jar download files? I tried both before, but I only tried the .exe since updating my Java. I'm trying the .jar again now.
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-18 01:37 am (UTC)
Stick with the .exe. The .jar is purely cross-platform and would require additional libraries for you to run it successfully.

The output looks good. I need to look at the launch script to figure out where the problem might lie. I'll have to do that tomorrow though.
(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-18 02:17 am (UTC)
Thanks for working so hard to help me, I really appreciate it!

After redownloading the .exe file and installing it, I'm still getting the "nothing happens" effect.
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-18 02:28 pm (UTC)
I built a new launcher that should give us some output and let us see what's happening a little better. Please download this file and copy it to wherever you installed Crosspost. By default it's in "C:\Program Files\Crosspost". Once you copy it there, just run it from that directory and let me know what output you get from it.

http://crosspost.sourceforge.net/CrosspostVerbose.exe
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-18 07:03 pm (UTC)
Just so you know...

When you run the new launcher I posted above, you can right click on the black screen with all the green text and you'll get an option to copy the contents to the clipboard, which you can then paste here.

=)
(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-18 09:55 pm (UTC)
Output folder: C:\PROGRAM FILES\CROSSPOST
Execute: "C:\Program Files\Java\jre1.5.0_06\bin\javaw.exe" -Djava.library.path="lib\swt-libs" -jar "dist\crosspost.jar"
Completed


Might this shed some light on my pesky little issue ^_^?
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-19 06:50 pm (UTC)
Not yet. =/

I just uploaded another version of CrosspostVerbose.exe. Please download using the above link and test again. This *should* provide even more output. It should actually bring up a console window when it tries to run...
(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-19 10:28 pm (UTC)
Output folder: C:\PROGRAM FILES\CROSSPOST
Execute: "C:\Program Files\Java\jre1.5.0_06\bin\java.exe" -Djava.library.path="lib\swt-libs" -jar "dist\crosspost.jar"
Completed

Now, when you say console window, do you mean an MSDos window? That's what I get, and it opens and closes instantly. I had to use PrtScrn to grab a screenshot of it:

http://img7.imageshack.us/img7/7695/java8xe.gif

This is the same thing that happened when I ran "java -version," though I simply typed that output since it wasn't too long.

So I guess another question I have is, Should these things be opening in DOS windows that vanish as soon as the output is displayed?
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-19 10:53 pm (UTC)
I failed to add the option to our little debugging launcher that keeps the window open, so this functioned as expected.

That output does help me some. Can you check your home directory (usually C:\Documents and Settings\Username) for a directory called "Crosspost" and, if it exists, delete it and run it again?
(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-19 11:13 pm (UTC)
I have C:\My Documents, C:\WINDOWS\All Users\Documents, and C:\WINDOWS\Profiles\Dustin\Application Data, but no folders named Documents and Settings\Dustin.

Also, I did a C search for folders named Crosspost, and the only folder by that name is the one in C:\Program Files.
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-19 11:15 pm (UTC)
Interesting.

It looks like it's having trouble setting up a profile for you. I'll be looking into this.

What OS are you using?
(Reply) (Parent) (Thread)
[User Picture]From: ompimec
2006-01-20 12:08 am (UTC)
Windows ME, the greatest OS ever x_x;
(Reply) (Parent) (Thread)
[User Picture]From: trippingbilly
2006-01-23 06:38 pm (UTC)
Nope, I haven't forgotten you.

Can you please try running Crosspost again for me. No, I'm not going mad. I made a few changes on the 'net side of things (which do not require a client update). I'm willing to bet it starts up for you now.

Also, if you plan on using MySpace, I suggest you upgrade to version 0.2.3-alpha as MySpace made some more changes to their site recently that required a Crosspost update.
(Reply) (Parent) (Thread) (Expand)