?

Log in

No account? Create an account
LiveJournal Client Discussions [entries|archive|friends|userinfo]
LiveJournal Client Discussions

[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

January 7th, 2007

XMLRPC, events wiyhout auth [Jan. 7th, 2007|05:04 pm]
LiveJournal Client Discussions

lj_clients

[madbox_lj]
Hi, all.
I trying to code my own client interface for LJ with XMLRPC for a few days.
I can't understand how to get public events from other user journals (i.e. without authentication).
There is no clear answer in http://www.livejournal.com/doc/server/ljp.csp.xml-rpc.protocol.html, may be i miss something?

help me please.
linkpost comment

(no subject) [Jan. 7th, 2007|09:31 pm]
LiveJournal Client Discussions
lj_clients
[sophiespo]
Hi everyone, I'm new here.

I used to do IT at uni, a long long time ago, I used to do a lot of programming, and I loved it. I'm doing a whole different course now, so that got put to the wayside.

I've always wanted to write my own LJ client, mostly because I'm never satisfied with any program I use (the common programmers curse - seeing the ways in which it can be better!). The only problem is, I never got past the trying to log in stage. It has just -never- worked for me. No matter what I try.

I've gone back to the basics, and am using Visual Basic .NET (I told you - basics!). I've read the documentation over and over again, and apart from noticing some bad grammar here and there, it's shining no new light on what I'm trying to do.

Can somebody please help me? This is what I've tried to do, and while relatively simple sounding, it just Will. Not. Do. It.

I have:

- created the TCP socket. It seems to connect fine to www.livejournal.com on port 80.
- sent the HTTP request stuff, as per http://www.livejournal.com/doc/server/ljp.csp.guide.intro.html says - so, the POST, Host, Content-type and Content-length.
- at the end of each line is either a vbCrLf code, or Chr(13) + Chr(10) (I've tried with both, but logically shouldn't be any different to each other?)
- after the content length, which I've set as the correct value, I put a blank line, then the "mode=login etc" line. Then another Cr Lf.

This responds with nothing. I remember, ages ago, I did it another way and it responded with something. It was the wrong value, and responded with an error, but I can't replicate it now.

I have my program listening on the incoming stream - I've tested it with a sample server to make sure that it will tell me if it receives any information.

I'm sorry to be such a complete newbie to this, but trust me, I wouldn't be asking if I hadn't already exhausted every possibility that I can think of. My head is this close: |-| to smashing against a wall, desk or whatever else is in reach. I've read back in this community before to try and find some answers, but can't.

Thanks in advance!
link6 comments|post comment

navigation
[ viewing | January 7th, 2007 ]
[ go | Previous Day|Next Day ]