?

Log in

No account? Create an account
Woes of a Mac user. - LiveJournal Client Discussions [entries|archive|friends|userinfo]
LiveJournal Client Discussions

[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

Woes of a Mac user. [Nov. 20th, 2006|03:00 pm]
LiveJournal Client Discussions

lj_clients

[spiffymunkee]
Hello!
I saw a [somewhat] recent entry about deleting all entires. However, I'd like to make all my entries private and the solutions that were commented on that post only seem to be for PCs. please correct me if i am wrong.

but ugh, please, a client that will do that for macs?

p.s. i use Safari.
linkReply

Comments:
[User Picture]From: ennev
2006-11-20 08:22 pm (UTC)
Even on a pc it's not that easy, you need to install perl language, then you have to use a script that is freeware on the internet. I'm sure that perl must be available to macs.
(Reply) (Thread)
[User Picture]From: gofasterstripes
2006-11-20 11:03 pm (UTC)

Perl?

It's included with a mac! My 10.4 has an interpreter ready and waiting. Just fire up Terminal.app and type 'perl' at the command line ;)
(Reply) (Parent) (Thread)
(Deleted comment)
[User Picture]From: kunzite1
2006-11-21 01:05 am (UTC)
how does your program handle metadata of the entries? location/mood/music/tags/etc?
(Reply) (Parent) (Thread)
(Deleted comment)
[User Picture]From: kunzite1
2006-11-21 05:48 am (UTC)
ahh... that's handy.
(Reply) (Parent) (Thread)
[User Picture]From: spiffymunkee
2006-11-21 08:34 pm (UTC)

thanks a lot.
i am new to the terminal and the perl languauge.
i tried using CPAN to insteal the modules and this is what it ultimately ended with:

Checking if your kit is complete...
Looks good
Writing Makefile for Date::Manip
-- NOT OK
Running make test
Can't test without successful make
Running make install
make had returned bad status, install seems impossible

so close yet so far. do you know what the problem could be?
(Reply) (Parent) (Thread)
[User Picture]From: spiffymunkee
2006-11-21 08:34 pm (UTC)
*install, too.
(Reply) (Parent) (Thread)
(Deleted comment)
[User Picture]From: aquarius0015
2006-11-29 04:57 am (UTC)

hi, mind if i hijack?

I installed XCODE and copy/pasted this:

sudo cpan install HTTP::Lite Digest::MD5 LWP::Simple Getopt::Long Date::Manip

and then I agreed to all of the default options... but i got this:

Checking if your kit is complete...
Looks good
Writing Makefile for Getopt::Long
-- NOT OK
Running make test
Can't test without successful make
Running make install
make had returned bad status, install seems impossible
Running install for module Date::Manip
Running make for S/SB/SBECK/DateManip-5.44.tar.gz
Is already unwrapped into directory /Users/andrew/.cpan/build/DateManip-5.44
Has already been processed within this session
Running make test
Can't test without successful make
Running make install
make had returned bad status, install seems impossible

what did i do wrong? i tried it three times, same result each time.
(Reply) (Parent) (Thread)
[User Picture]From: soundwave106
2006-11-22 04:05 pm (UTC)
Actually, what the person is referring to is probably this program I wrote (LJ-Sec). It is written in C#.Net.

Because it is .Net, it is best handled on the PC right now. But the open-source Mono.Net project *is* chugging along (including Mono.Net for OS X), and there is a fork of the program that is compatible (theoretically) with Mono.Net.

Just because it is compatible with Mono.Net doesn't mean that running this on the Macintosh is very easy, yet. I know with various Linux flavors, graphics packages may need to be downloaded in addition to the Mono distribution.

I have no access to a Macintosh right now, elsewise I'd work to provide a binary, and installation instructions for OS X machines. For now, the Perl script on OS X is the best bet.
(Reply) (Parent) (Thread)
(Deleted comment)
[User Picture]From: soundwave106
2006-11-24 06:32 am (UTC)
I've learned a long time ago that just because something *claims* to be cross-platform doesn't mean it is without a bit of work. :)

An example: SharpDevelop (what I used to test-compile the Mono fork) doesn't play 100% nice with Microsoft's .NET GUI, and vice versa. With LJ-Sec I had to modify a few things in the menu portion of the code (and a couple other little things) to get it to work. Same CPU, same OS, same platform, same CLR, different GUIs.
(Reply) (Parent) (Thread)
From: senatortreason
2006-11-25 07:16 am (UTC)
I think you can use jbackup.pl to change the security setting on all of your posts. Similar requirements and usage as the above regarding perl and ljsecedit.
http://code.sixapart.com/svn/livejournal/trunk/src/jbackup/jbackup.pl
(Reply) (Thread)
From: ex_axl_koli
2006-12-27 08:33 pm (UTC)

I cant uploud Jpeg!!!!

Why I cant to load foto from my hard disk to my lj? After push button "upload" it's loading but suddenly interrupting and its as a usual.
HELP!!!! AAAAAAAAAAAAA!!!!!!
(Reply) (Thread)