?

Log in

No account? Create an account
Archiving Entries? - LiveJournal Client Discussions — LiveJournal [entries|archive|friends|userinfo]
LiveJournal Client Discussions

[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

Archiving Entries? [Dec. 12th, 2006|06:47 pm]
LiveJournal Client Discussions

lj_clients

[rebeccael]
Hi,
I'm trying to find a way to mass download as many entries as possible with comments, which the LJ Exporter won't let me do. Also, it would be awesome if they downloaded in some readable form that preserved formatting, instead of with a bunch of HTML or other code inserted. Is there a client that will let me do that, or any other way for me to do it? Thanks!
Breca
linkReply

Comments:
[User Picture]From: natf
2007-01-17 03:30 pm (UTC)
Ty for your help. As I say, I used to *do* Perl but my brane got eaten by the multiple sclerosis...
(Reply) (Parent) (Thread)
[User Picture]From: ati
2007-01-17 03:39 pm (UTC)
Ty for giving it a try :)
(Reply) (Parent) (Thread)
[User Picture]From: 2shortplanks
2007-01-17 09:37 pm (UTC)
Nat, it looks like "make" isn't working. This is probably because it isn't installed - it's not by default on Mac OS X.

You need to install the developer tools. A version should have shipped on a separate disk with your mac, but that's probably out of date now (but will still work if you have it.)

I suggest you sign up for an ADC account from http://developer.apple.com/. Once you've got one (nothing more complicated than a username and password and email address to sign up) you'll be able to download the 938.2MB of developer tools as a DMG. Once you've got that installing it as simple as double clicking the image, and then double clicking the XCodeTool.mpkg inside that.

installing LWP should then be as simple as:

$ sudo cpan
(answer "no" to the "are you ready for manual setup" to use the defaults)
cpan> install LWP::UserAgent

If you have problems getting the developer tools then drop me a line and I'll burn you a DVD with them on and stick 'em in the post.
(Reply) (Parent) (Thread)
[User Picture]From: natf
2007-01-18 12:04 pm (UTC)
Ah hah! I had X11 installed and so I assumed that I had all of the developer tools installed! ;-p

I will give that a try!
(Reply) (Parent) (Thread)
[User Picture]From: natf
2007-01-18 04:10 pm (UTC)
Installed XCodeTools.mpkg then did:

$ sudo cpan
(answer "no" to the "are you ready for manual setup" to use the defaults)
cpan> install LWP::UserAgent


Then got:

"...
Checking for URI........... ok
Checking for HTML::Parser.. ok
Checking for MIME::Base64.. ok
Checking for Net::FTP...... ok
Checking for Digest::MD5 .. ok

Checking if your kit is complete...
Looks good
Writing Makefile for LWP
-- NOT OK
Running make test
Can't test without successful make
Running make install
make had returned bad status, install seems impossible"

Stuck again.
(Reply) (Parent) (Thread)